Back to overview
Downtime
Feedback System Downtime
May 19 at 04:00am BST
Affected services
Feedback System
Resolved
May 19 at 09:54am BST
The issue with the Feedback system has now been resolved.
Affected services
Created
May 19 at 04:00am BST
The Feedback system is experiencing an issue preventing access.
Affected services