Back to overview
Downtime
Feedback, Ethics and Assessment Systems Unavailable
Nov 01 at 03:00pm GMT
Affected services
Assessment System
Feedback System
Undergraduate Ethics
Postgraduate Ethics
Resolved
Nov 01 at 03:30pm GMT
We have identified and resolved the cause of the issue and systems have now been restored.
Affected services
Created
Nov 01 at 03:00pm GMT
There is an issue currently affecting some fse.network systems. We are currently working to resolve this issue.
Affected services